Create Pro by MacFinder

Forums

Modded Mac pro 5,1 upgrade to mojave rabbit hole, can she be saved

Home Create Pro Forums Mac Desktops Mac Pro Mac Pro 2009-2012 Modded Mac pro 5,1 upgrade to mojave rabbit hole, can she be saved

1 month, 2 weeks ago
  • This topic has 0 replies, 1 voice, and was last updated No Replies by Avatarxaeretvfx.
Viewing 1 post (of 1 total)
  • Author
    Posts
    • Helpful
      Up
      0
      Down
      Not Helpful
      Avatarxaeretvfx
      Mac User
      #417120

      Hi there. so ive got a modded mac pro 5,1 that i bought and owned directly from apple in 2012 (so im the only owner).

      The mods that are relevant to this are as follows:

      GTX 980ti (unflashed)

      EVGA G2 1000w gold+ PSU powering the gpu fully

      Now this problem was purely from my own lack of research.

      As apple advised in their guide on how to install mojave on a 5,1: i upgraded my firmware to 144.0.0.0.0

      This worked fine, and had no issues. i should have left it here, <u>but i got greedy.</u>

      i run mojave on my 2019 macbook pro, running final cut pro X for some of my indie projects i run a newer version on my laptop that is not compatible with os 10.13.6 (my Mac Pro OS at this time), so i wanted to upgrade for this reason.

      So i started with removing my Raedon 5870, which i run together with the 980ti powering different displays. I did this because the mojave installer thinks the 5870 is my only gpu when its in there.

      So i start the installer with the 5870 removed, it allows me to go ahead with upgrading my firmware. i upgrade the firmware (as mentioned earlier) and start it back up. now im able to install, great!

      i begin the installation, it goes smooth for the first phase, when it restarts i knew i wouldnt see a boot screen for awhile as there was that second progress bar to go through. what i didnt know was there were no web drivers compatible, after an hour i shut the computer down via power button. i then added my 5870 back in, and rebooted holding option to choose my disk. it gave me 2 options: Mac os installer or Macintosh SSD

      i chose Macintosh SSD, it manages to boot but there is obvious visual glitches and running horribly (as its using the unsupported GPU) i realize my mistake after checking the nvidia drivers and checking for updates.

      my next step was to try and get high sierra back.. ok recovery mode should work?

      boot up using CMD+R…. works fine. but only option is to reinstall mojave.. which it doesnt allow me because my amd gpu is not metal capable, and i cant use the nvidia only because i wont see the recovery screen.

      So i have a time machine backup.. many of them.. wipe the disk using disk utility and start a restore

      1st snapshot fails @ 98GB

      2nd snapshot fails @ unknown size (around the same)

      3rd snapshot fails @ 98GB

      try internet recovery mode

      CMD+shift+opt+R… prohibitory symbol… eventually boots into normal recovery mode revealing mojave as option

      opt+R… prohibitory symbol, same as above.

      so my next option is to wipe the drive, use my macbook pro to create a bootable installer of os high sierra and use that to fix my **** mac pro.

      so i do my normally google for the apple link to get os high sierra, it takes me to the MAS, great! i click “Get”… im running mac os 10.4.6 on this macbook, so it takes me to “software update” in system preferences, where it proceedes to give me this error

      it should be noted aftter some research, i found this workaround WORKED FINE before the release of os catalina. now the catalina has been released this feature is not possible.

      great… so more research turns up there is a terminal command that will directly download a mac os installer via apple servers.. this command only works on OS catalina

      i am a VFX artist and on-set coordinator in the film industry, so i rely on many applications and plugins.. many of which are not compatible with cataline yet, meaning upgrading is not an option

      I’ve managed to download OS sierra (Which is literally just a direct link download dmg from apple, on an article “how to install mac os sierra” that is the EXACT same format as the high sierra article, yet the high sierra link goes to the app store..

      so i contact apple support to get a solution to this, they advise me i must upgrade my laptop.

      so apple’s solution was to advise me to lose my job until the devs can catch up with their yearly BS

      so now im frustrated, and need some advice from a community member as i shouldve come here first anyways.

      Should i:

      • install Mac os sierra via bootable installer, install my nvidia drivers, ensure they work and then upgrade to high sierra via upgrade or time machine backup?

      or

      • keep trying to restore my machine from a backup hoping one of my many snapshots will work

      or

      • try to find someone or (PREFERABLY APPLE!!!) to provide me with a mac os high sierra installer dmg
      Attachments:
  • Log in or Register to leave a comment

Join the ultimate Mac Pro community

Upgrade Your Mac Pro

Have a Mac Pro that needs upgrading?

  • Send us your whole workstation
  • Or send us your processor board
  • We return your fully upgraded Mac Pro
Upgrade Today

Configure Your Mac Pro

Build the Mac Pro you need from the ground up

  • Built bespoke to your needs
  • Industry leading 3 year warranty
  • Refurbished and built by our certified technicians
Configure Your Mac Pro