Create Pro by MacFinder

Forums

MAcPro 5,1 not too old ?

Home Create Pro Forums Products Desktops Mac Pro Mac Pro 2009-2012 MAcPro 5,1 not too old ?

3 weeks ago
2
  • This topic has 2 replies, 2 voices, and was last updated No Replies by AvatarCharles.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
    • Up
      0
      Down
      Avatar.H.
      Mac User
      #417533

      Hi,

       

      i have a MacPro 5,1 (2009 )

      i would know what OS can i install on it

      if it’s not too old to use the latest OS

       

       

      thanks

       

    • Up
      0
      Down
      AvatarCharles
      Create Pro Staff
      #417534

      Which graphics card do you have?

      Looks like you have the 5,1 firmware so you will be able to go up to high Sierra, with metal capable card you can get up to 10.14 Mojave and then with opencore installed you can upgrade to Big Sur.

       

       

       

    • Up
      0
      Down
      AvatarCharles
      Create Pro Staff
      #417535

      Which graphics card do you have?

      Looks like you have the 5,1 firmware so you will be able to go up to high Sierra, with metal capable card you can get up to 10.14 Mojave and then with opencore installed you can upgrade to Big Sur.

       

       

       

  • Log in or Register to leave a comment

Join the ultimate Mac Pro community

High Performance MacBook Pros

Is it time to upgrade your portable workstation?

  • Save over 20% from retail
  • Huge range of models to choose from
  • Up to 3 years warranty
Upgrade Today

Configure Your Mac Pro

Build the Mac Pro you need from the ground up

  • Built bespoke to your needs
  • Industry leading 3 year warranty
  • Refurbished and built by our certified technicians
Configure Your Mac Pro